1. Welcome to Autism Forums, a friendly forum to discuss Aspergers Syndrome, Autism, High Functioning Autism and related conditions.

    Your voice is missing! You will need to register to get access to the following site features:
    • Reply to discussions and create your own threads.
    • Our modern chat room. No add-ons or extensions required, just login and start chatting!
    • Private Member only forums for more serious discussions that you may wish to not have guests or search engines access to.
    • Your very own blog. Write about anything you like on your own individual blog.

    We hope to see you as a part of our community soon! Please also check us out @ https://www.twitter.com/aspiescentral

How is your mobile browsing experience.

Discussion in 'Site Questions, Suggestions & Feedback' started by Brent, Feb 20, 2014.

  1. Brent

    Brent Administrator Staff Member Admin

    Messages:
    1,161
    Joined:
    Nov 4, 2013
    Karma:
    +1,429
    For those that do not use our iOS or Android apps, how do you like browsing the forum on your phone using your web browser?
     
  2. 142857

    142857 Well-Known Member V.I.P Member

    Messages:
    767
    Joined:
    Jan 19, 2010
    Karma:
    +144
    I am browsing on iOS (iphone) and it is fine. Haven't had any issues.
     
    • Like Like x 1
  3. King_Oni

    King_Oni Well-Known Member V.I.P Member

    Messages:
    5,631
    Joined:
    Sep 6, 2011
    Karma:
    +5,246
    I'm using Internet explorer on Windows phone.

    I haven't come across any actual issues while browsing, except for the obvious ones that happen on any mobile device. Things get resized, buttons get jumbled around a bit and end up stack up rather than next to each other, which doesn't change at all when I change to landscape mode. I guess IE on WP doesn't want to utilize the horizontal scrollbar too much (which is fine, since going from left to right to read something is annoying).

    The minor thing I could comment on; the buttons are relatively big on mobile devices. Obviously tablets are big enough, but not every smartphone is sized like a Samsung Galaxy Note (you know, between a smartphone and a tablet). So to be sure I don't accidentally hit the wrong button, I'd rather zoom in a bit. They're spaced nicely though, so misclicking wouldn't occur as much. Portrait mode has the Report and "select post" button (for us Moderators) really close to each other in portrait mode (but I rarely browse in portrait mode; at least forums usually go in landscape for me personally).

    I've tried Tapatalk on my phone as well... seems fine for browsing, just not for moderating, heh.

    That's what I've ran into thus far. Still trying out some odd ball things, which I never even used on a regular computer, just to see if there's no glitches here.

    I'm not an expert on Windows phone, but given it's small group of users (and I don't even know if anyone on this forum has this OS on their phone) I guess things related to such phones (and perhaps my phone in particular when it comes to browsing AC; I have a Nokia Lumia 1020) and testing them out on such a device could always go to me.
     
    • Like Like x 1
  4. wyverary

    wyverary Bare-footed hippie V.I.P Member

    Messages:
    7,076
    Joined:
    Jun 24, 2012
    Karma:
    +7,147
    Thus far it's been working well enough--quite well, in fact--that I don't even use Tapatalk anymore unless I want to post a picture. Of course, I rarely use it on my phone, but on the iPad it works much better than the old site used to.
     
  5. Turnip

    Turnip Well-Known Member

    Messages:
    193
    Joined:
    Feb 17, 2014
    Karma:
    +50
    Tried the site on my mobile today. Browsing was functional and the site looked good (pages seemed a little heavy to load over 3G), but the rich edit box to reply to a thread was not usable - typed characters took minutes(!) to show up.

    Not sure if this is of concern though as my mobile runs neither iOS nor Android - I'm running Maemo Linux (the native OS for my phone, a Nokia N900) and the browser was MicroB (also native) - a Firefox variant (equivalent to Firefox 3.5).
     
  6. 142857

    142857 Well-Known Member V.I.P Member

    Messages:
    767
    Joined:
    Jan 19, 2010
    Karma:
    +144
    I can't work out how to do a search using my iPhone. Apart from that it's still all good.
     
  7. Brent

    Brent Administrator Staff Member Admin

    Messages:
    1,161
    Joined:
    Nov 4, 2013
    Karma:
    +1,429
    Next to alerts tab you will see a small magnifying glass icon. Clicking that will allow you to search.
     
  8. Brent

    Brent Administrator Staff Member Admin

    Messages:
    1,161
    Joined:
    Nov 4, 2013
    Karma:
    +1,429
    I do not think the forum software is designed for older browsers like that. Especially for mobile.
     
  9. Turnip

    Turnip Well-Known Member

    Messages:
    193
    Joined:
    Feb 17, 2014
    Karma:
    +50
    Well, I'm not convinced that the age of my browser is the issue... and you didn't suggest browsers more than a year or two old weren't included in your request for feedback; you requested only "For those that do not use our iOS or Android apps, how do you like browsing the forum on your phone using your web browser?" which is exactly what I tested - if you don't care if it works on my configuration that's up to you, but then I feel you should have been clearer and when I made sure to include the details of my test and give you an out for not wanting to support a config that we both I suppose expect makes represents a tiny proportion of your traffic I feel you could expressed that without blaming arbitary specs seemingly without any justification.

    Further testing would suggest that if I ask my browser to lie to the web and say it's the Safari-based iPhone 4 browser Apple ships, then the issue goes away; however it goes away because if my browser lies then this site removes the feature I reported the issue with(the BBcode WYSIWYG editor) from the page which is served.

    Thus, unless I'm missing something the implication of what I've seen is that issue's got nothing to do with my browser specifically, or it's age... I would thus appreciate confirmation that other mobile browsers are given only the BBcode source editor without the button to switch to the WYSIWYG version (which otherwise is default)?
    (incidentally when my phone is served the page with the WYSIWYG BBcode editor, clicking the button to switch to the non-WYSIWYG editor also takes a very long time, ie. minutes)

    Further possible test case (seemed like it could be a bug): Start typing a message in the WYSIWYG editor for a thread on a desktop browser, let it be saved as a draft, now visit the thread with a mobile, the draft text should show, are you about to continue with the message or do you have to clear the draft from the desktop before you can reply to that thread?
     
    Last edited: Feb 26, 2014
  10. 142857

    142857 Well-Known Member V.I.P Member

    Messages:
    767
    Joined:
    Jan 19, 2010
    Karma:
    +144
    Th
    Thanks, that works.
     
  11. superboyian

    superboyian supermodian V.I.P Member

    Messages:
    3,044
    Joined:
    Jan 30, 2010
    Karma:
    +553
    Seems to be working fine on my Windows Phone.
     
  12. Manuheleku

    Manuheleku Well-Known Member V.I.P Member

    Messages:
    3,473
    Joined:
    Feb 15, 2014
    Karma:
    +1,606
    The Android app works great, I've been using it exclusively since becoming a member and haven't had problem one. Posting is easy, url's seem to work (YouTube videos) fine, I haven't uploaded a picture in a message yet, guess I'll figure that out eventually.
     
    • Like Like x 1
  13. Manuheleku

    Manuheleku Well-Known Member V.I.P Member

    Messages:
    3,473
    Joined:
    Feb 15, 2014
    Karma:
    +1,606
    Testing pictures...
     

    Attached Files:

    • Like Like x 1
  14. Vanilla

    Vanilla Your friendly neighbourhood hedgehog V.I.P Member

    Messages:
    2,449
    Joined:
    Dec 19, 2013
    Karma:
    +2,600
    I use an ipad for my browsing; seems to work fine. I do prefer the web browser to the app, just as it's a bit warmer in appearance, and has many more options.
     
    • Like Like x 2
  15. Salmongirl17

    Salmongirl17 I'll try to make a full return

    Messages:
    504
    Joined:
    Feb 5, 2014
    Karma:
    +199
    Lol I've only ever used my ipod5! I don't even really know what it looks like from a computer point of view!
     
  16. Kuribo

    Kuribo ☮☮☮☮

    Messages:
    155
    Joined:
    Mar 5, 2013
    Karma:
    +88
    The mobile browsing experience here is better than on most other forums. The responsive design works very well, and I never feel like I'm having a limited or otherwise inferior experience, as I do on most mobile sites.

    I'm just curious, would it be possible to add an option for users to disable the site's responsive design in preferences? While it's great for smaller devices, I personally find it distracting and unnecessary on my iPad.
     
  17. Manuheleku

    Manuheleku Well-Known Member V.I.P Member

    Messages:
    3,473
    Joined:
    Feb 15, 2014
    Karma:
    +1,606
    Is there an issue with the Android app or is it just me?
     
  18. Vanilla

    Vanilla Your friendly neighbourhood hedgehog V.I.P Member

    Messages:
    2,449
    Joined:
    Dec 19, 2013
    Karma:
    +2,600
    Brent's tinkering with some new stuff for the website, to make it more secure, so could be related to that.
     
  19. Brent

    Brent Administrator Staff Member Admin

    Messages:
    1,161
    Joined:
    Nov 4, 2013
    Karma:
    +1,429
    Will be fixed shortly. May need to restart
     
  20. Manuheleku

    Manuheleku Well-Known Member V.I.P Member

    Messages:
    3,473
    Joined:
    Feb 15, 2014
    Karma:
    +1,606
    Thanks, I really like the app, much better than the mobile browser.