• Welcome to Autism Forums, a friendly forum to discuss Aspergers Syndrome, Autism, High Functioning Autism and related conditions.

    Your voice is missing! You will need to register to get access to the following site features:
    • Reply to discussions and create your own threads.
    • Our modern chat room. No add-ons or extensions required, just login and start chatting!
    • Private Member only forums for more serious discussions that you may wish to not have guests or search engines access to.
    • Your very own blog. Write about anything you like on your own individual blog.

    We hope to see you as a part of our community soon! Please also check us out @ https://www.twitter.com/aspiescentral

Adventures Flash Modding 3rd Generation iPods

MildredHubble

Well-Known Member
V.I.P Member
Just needed to let off some steam about what I've been working on. I guess this is me infodumping. I dunno, maybe someone will find it interesting!

I posted a while back that I had successfully modified my ancient 3rd Generation iPod to use efficient modern SD cards as storage. So I fixed up my near 20 year old iPod and bought the appropriate adapters and while it was a bit of a headache, with a lot of lateral thinking, I got it all working. Pretty neat :)

So I thought it would be a great idea to repeat the process with another identical iPod. I had a spare compact flash adapter and a compact flash to mini IDE adapter. So when I assembled everything I thought I'd just need to repeat the process to restore it in iTunes, but I discovered that my spare compact flash adapter didn't work, even when I switched it for my working SD card. Oh dear :(

They look identical from the outside but apparently they weren't on the inside. So I figured the firmware (code written on a chip to tell the adapter how to function) might be different.

So, I disassembled my working iPod and removed the working compact flash adapter and removed the adapters casing. I found a little chip (pretty tiny actually) that looked like a "flash" chip that years of experience tells me is likely where the firmware lives.

image.jpg

It's that little black rectangle with 8 pins in the top left. So I used my hot air solder station to heat it up enough to melt the solder and removed it from the board using tweezers and this is what I ended up with...
IMG_20231102_203925_008.jpg

Photo is a bit rubbish as it's taken from the screen my microscope is connected to.

So now I have the chip I should be able to connect it to my flash chip programmer and read and save it's contents. I can then copy it's contents to the nonfunctional compact flash adapter and hopefully it will allow it to work in the iPod too! Only slight problem is that I don't have the right sized adapter to connect it up. So I had to do something slightly silly and bend all the metal pins out just enough so that they would reach the contacts and could be soldered in place...
IMG_20231102_202213_450.jpg

Against the odds I managed without breaking the pins and that's it inserted into my flash chip programmer. I was able to find a reading algorithm in the software that worked with the chip so I saved all it's binary goodness to transfer to the other chip.
IMG_20231102_202808_213.jpg

So now I carefully desoldered the chip and bent the pins back into position and soldered it back onto it's circuit board. So I'm sure it's relieved it's ordeal is over and thankful I didn't break it!

I had to repeat the same process for the the other board and bend the pins out so I could program it with the new firmware. Then I had to solder it back to its board like so...

IMG_20231102_204210_590.jpg

Then I noticed I had knocked a component off the board to the left of the chip! Fortunately testing the other board revealed that it was just a 0ohm resister link! So I was able to just bridge it with solder! Phew! :oops:
IMG_20231102_205116_417.jpg

So after a clean up to remove the flux from the board (that's the slimy stuff you can see, it helps the solder flow on to the joint better) I put it back into it's case. Grabbed my working SD card and put the board that hadn't worked back into the iPod. And......IT WORKED!!!! :D

I kept the formally nonfunctional/incompatible adapter in my iPod for a few days and it worked just fine. I also reinstated the original one back into my iPod and both functioned identically. So I was confident I hadn't just mixed them up! :smilecat:

So now all I needed to do was get a nice SD card and go through the software restore process. Buuuuut, that's where things went off the rails! Using either adapter the restore process fails regardless of which adapter I use, but my original SD card works just fine! I can't figure it out, but it appears that there's something special about it. I tried buying an identical one but it just won't work! Drat! :(

So that's as far as I've gotten. I will hopefully figure it out. I really hoped this iPod would make a nice Christmas gift for my Dad! So I have lots of testing and figuring out to do. Wish me luck! :smilecat:
 

Slime_Punk

 Please erase
V.I.P Member
This is wild. I definitely want to hear progress updates on this one! I wonder what it likes about one SD card over another, though. That's really strange!
 

MildredHubble

Well-Known Member
V.I.P Member
This is wild. I definitely want to hear progress updates on this one! I wonder what it likes about one SD card over another, though. That's really strange!
Thanks! I thought it might be kinda fun to document what I was doing a bit :) I'm really not sure why the SD cards are showing different behaviour. Unfortunately you can't really be sure that they are manufactured to the same specifications. They may look identical from the same brand but use different controllers and flash RAM.

But I felt fairly sure that a brand like PNY would be fairly consistent. My hope is that it has something to do with the partitioning/formatting. Even though you might format the cards the OS might do it in an expedient way, for example just erasing the directory database. This makes ithe card look empty when really it's not and the ipod may read the card in a more direct way which may cause read/write errors.

I'm running a full format which will take a while but my hope is that this will solve the issues! :)
 

MildredHubble

Well-Known Member
V.I.P Member
Yay! I got it working! It turns out the IDE connection on the iPod was a bit flakey and it also seems to help if you format the SD card while it's in the iPod. The restore process completed without a hitch and then syncing the iPod went just find after that as you can see here...
IMG_20231129_190303_702~2.jpg

I've been listening to it for a while and it seems to be working fine. I also installed a boost module to enable it to charge over USB rather than the original FireWire. This seems to cause a couple of quirks when the computer "ejects" the iPod but it seems just rebooting the iPod by holding down the Menu and Play/Pause buttons solves that. The screen also freezes after a few minutes when charging via USB, again, not sure why but it's fine when you disconnect the cable. It's probably some half finished USB stuff in the Firmware, but not really a show stopper as issues go! :)
 

New Threads

Top Bottom